Siga o Blog por E-mail

domingo, 29 de agosto de 2010

Removendo objetos do Exchange Server 2010 do Active Directory

Boa noite pessoal!!
Vou dividir uma solução aqui com vocês.
Imaginem assim, você está fazendo a implementação de uma infraestrutura Exchange Server 2010, os servidores do Exchange em Hyper-V . Como você está implementando o Exchange 2010 ainda, você não tem um backup.
Ai logo depois da instalação do Exchange Server 2010 “CAS-HUB-MBX” você faz a conexão com o servidor Exchange 2010 “Edge Transport”, tudo ficando muito bonito e maravilhoso. Depois de ter terminado tudo, já mandando e-mail e recebendo tudo ok.
Primeiro começa a não receber e-mail, depois não consegue enviar, ai começa o trobloshoting, conectores OK, serviços OK, resumindo tudo OK, vou reiniciar ver se volta né.
E nada, bom como não tem ainda as mail boxes vou remover e adicionar de novo, procedimento tranquilo.
Mas sabe aquele dia que tudo dá errado????
Então este era o dia.
Removeu o Exchange sem erro, você olha e não tem mais nada lá.
Bom, iniciei a instalação de novo, ai fui almoçar e deixei instalando, quando eu voltei ele adicionou o novo servidor Exchange na organização que eu tinha acabado de desinstalar.
Essa é uma daquelas horas que você começa a esquentar a cabeça.
O Problema é que a desinstalação do Exchange deixou os objetos no Active Directory
Bom, aqui está a solução que eu arrumei.

Removendo objetos do Exchange Server 2010 do Active Directory:

1. Vá no controlador de domínio

2. abra ADSIEDIT

3. clique com o direito em ADSIEdit

4. Conectar em “Default Naming Context”

5. Vá até esses objetos e delete.

DC=Domain,DC=Com -> OU=Microsoft Exchange Security Groups
DC=Domain,DC=Com -> CN=Microsoft Exchange System Objects

6. Clique novamente com o botão direito em ADSIEdit

7. Conectar em “Configuration”

8. Vá até os objetos abaixo e delete.

CN=Configuration,DC=Domain,DC=Com -> CN=Services -> CN=Microsoft Exchange
CN=Configuration,DC=Domain,DC=Com -> CN=Services -> CN=Microsoft Exchange Autodiscover

9. Force a replicação do Active directory.

10. Pronto os objetos referentes ao Exchange no Active directory não existem mais.

Agora ficou tudo tranquilo!!!
Iniciei a nova instalação!!!
Tudo implementado e funcionando!!!
Abraço a todos!!!

2 comentários:

  1. Simples e funcional. Muito bom o Post Ewerton.
    Abs,
    André Vieira

    ResponderExcluir
  2. legal, mas e se caso houver um exchange 2003 nessa rede, e estiver precisando refazer um 2010 que foi adicionado nesta rede?

    ResponderExcluir